Website Guide for Content Managers

For the building and maintenance of the Armstrong State University website, powered by ExpressionEngine.
Contents

Navigating ExpressionEngine ........................................................................................................ 3
The Control Panel ....................................................................................................................... 3
Page Layouts & Creation ............................................................................................................... 5
Layout 1 – Homepage ................................................................................................................... 5
Layout 2 – Main_Body Page (or channel index/landing) .............................................................. 7
Create A Main_Body Page .......................................................................................................... 8
Layout 3 – Detail Page (or level 2_body) ................................................................................... 9
Create A Detail Page Entry ....................................................................................................... 10
Modify a Main Body or Level 1 Entry ....................................................................................... 12
Modify a Detail Entry ............................................................................................................... 13
Adding Contact Information and Social Media ......................................................................... 14
Updating the Navigation (depending on your level of access) .................................................. 15
Adding a Navigation Item ........................................................................................................ 15
Editing/Moving a Navigation Item .......................................................................................... 16
Deleting a Navigation Item ...................................................................................................... 16
Assets ........................................................................................................................................ 17
Add A Sub Folder ..................................................................................................................... 17
Modifying Subfolders .............................................................................................................. 17
WYGWAM Editor ..................................................................................................................... 18
Navigating ExpressionEngine

The Armstrong State University website is built and managed in a content management system called Expression Engine. This section will explain the how to navigate the control panel.

The Control Panel

*Note: To return to the main dashboard at any time, click the home button 🏡 in the upper left corner. Make sure you have saved your work first!

As a content manager, you will have access to create, edit and view content on the site. The dashboard (shown above) has three main menus to access the information you will utilize most frequently.

When you click the **Entry** option under **Create**, you are given a choice of channels as to where the content will reside.

As a content manager, your login is restricted to the pages and information that you manage for your department. If you are not able to view/edit content that you should be able to, please contact ________________.
When you click the **Entry** option under **Modify**, you are presented with a new window that shows all existing content that can be searched and filtered. The entries you see in the table is based on the permission levels for your access. You can search with the keywords or use the filter by Channel to find the entry you are looking for.

If you need to access an entry that you have recently edited or created, you can use the **Recent Entries** under the **View** menu.

In the black menu bar, you have access to three items: Content, Members, and Help.

- **Content** provides the same features as the main control panel: create (publish), edit (Modify), or access to the File Manager where you can upload your images and files.
- **Members** allows the user to view other members only.
- **Help** – The help feature will take you directly to Expression Engine help depending where you are on the site. For example: if you are editing an entry and click help, a new tab will open in your browser with the help information for that feature of Expression Engine. You can also access the main user guide through this link: [https://ellislab.com/expressionengine/user-guide/index.html](https://ellislab.com/expressionengine/user-guide/index.html) or by going to the View menu and click User Guide.
Page Layouts & Creation

There are 8 main layouts for the site pages. These layouts are a combination of elements that make up the design of the page. This section describes each layout with the elements on the displayed page.

**Layout 1 – Homepage**

1. **Header** – this section is consistent throughout all page layouts and included on each template.
   a. Logo – Static element, cannot be changed
   b. Top Navigation & Search – No drop downs. Can be modified through NavEE.
   c. Main Navigation – Can be modified through NavEE. Only displays top 2 levels.

2. **Body** – Index1
   a. **Hero Image/Carousel** – These images and text can be scrolled through and/or click the > to view access to the featured story in News. Maximum of 10 images/stories.
   b. **Audience Navigation** – This navigation is only available on the home page. However there are links to this section throughout the site. Can be modified through NavEE.
   d. **Events** – Shows featured events. Links to event details. Autopopulated.
   e. **Yellow Call-To-Actions** – These are an element on every page layout on the site. Can be modified through Snippets.
   f. **By The Numbers** – Facts on homepage only. Contains 6 fields: one each for number and description. Styling is set.
   g. **Armstrong Social** – Autopopulated through APIs.
   h. **Degree Program Search** – Hard coded through the template.

3. **Footer** – modified through template>footer.
Layout 2 – Main_Body Page (or channel index/landing)

1. Header
2. Body – Main_Body
   a. Page Title
   b. Hero Image/Carousel – These images and text can be scrolled through and/or click the > to view access to the featured story in News. Maximum of 10 images/stories. If only one image entered, then it is static.
   c. Quick Links – up to 10 additional links
   d. Headline
   e. Body Content – edited through WYSIWYG/HTML
   f. Visual Navigation – Maximum of 8 boxes and secondary links
   g. Profiles – randomly and automatically populated based on channel.
Create A Main_Body Page

1. Go to the control panel
2. Choose Create>Entry
3. Choose the appropriate channel. (Administrative departments do not have this type of page)

- **Editable regions**
  a. **Page Title** – used in URL
  b. **Hero Image/Carousel** – Image, title, caption for each instance.
  c. **Quick Links** – URL and Text for each instance.
  d. **Headline**
  e. **Body Content** – edited through WYSIWYG/HTML
  f. **Visual Navigation** – Image, Headline, Headline URL, Link and Link text (up to 10)
Layout 3 – Detail Page (or level 2_body)

1. Body – detail
   a. Page Title
   b. Main Image – 580 px wide Only one allowed.
   c. Left Navigation
   d. Quick Links – up to 10 additional links
   e. Body Content – edited through WYSIWYG/HTML
   f. Link Buttons – Maximum of 8 buttons
   g. Lower Content Areas – WYSIWYG/HTML
Create A Detail Page Entry

1. Go to the control panel
2. Choose Create>Entry
3. Choose the appropriate channel. Administrative departments use the level2_body channel and the academic departments should have their own channel.
1. Page Title – used in URL
2. Hero Image – from Assets
3. Body Content – WYSIWIG or HTML
4. Quick Links – Up to 10 entries
5. Link Buttons – Up to 8 entries
6. Visual Navigation – Up to 8 entries
7. Lower Content Areas – WYSIWIG or HTML
8. Submit (save)
Modify a Main Body or Level 1 Entry

1. From the dashboard, go to the Modify or delete menu.
2. Choose Entry.
3. In the Filter by Channel drop down, choose Level1_body.
4. Find the appropriate titled content and click the red title to open the content screen.
5. Make your changes and click the submit button.
Modify a Detail Entry

1. From the dashboard, go to the **Modify or delete** menu.
2. Choose **Entry**.
3. In the **Filter by Channel** drop down, choose **Level2_body**.
4. Find the appropriate titled content and click the **red title** to open the content screen.
5. Make your changes and click the submit button.
Adding Contact Information and Social Media

Contact Information and Social Media should have been preset on all your existing content pages in the left sidebar. However, you may need to add/edit information as it changes.

**Step 1** – Validate the existing contact information and social media links. Check the public facing website pages to ensure the data is displaying correctly.

**Step 2** – Go to the CMS and choose Content>Edit>Contact Information. Search for the appropriate entry. Validate the information.

**Step 3** – Update the contact info field or the appropriate social media field.

*Note: The contact info field is in HTML format and needs to remain in this format to display properly. `<h3>` or `<h2>` is the header size for “Contact Information.” All other text should be included in paragraph tags `<p>` and use the line break as needed `<br/>`."

If you have added new content pages to your site, you will also need to ensure that the contact information displays on those pages as well. Go to the created content page in the CMS and scroll to the bottom of the page. In order for the contact information to appear on the page, you may need to override the parent information. To do this, click the drop down and choose the appropriate contact information from the list and check the box YES to override.
Updating the Navigation (depending on your level of access)

After the content has been added, the main navigation should be updated in the NavEE module.

To edit the NavEE module, click Add-ons>Modules>NavEE.

From the main NavEE screen, choose Main Nav.

Once in the NavEE module, review the existing structure to see if your page/content has a placeholder.

Adding a Navigation Item

1. Click the Add Item button above the navigation list.
2. In the box on the right enter the following information
   a. **Link Text** – this is the text that will appear in the menus
   b. **Assign Link to Parent** – Click the drop down and determine where this content will appear in the site.
   c. **Create Link** – Make sure the **Manual** button is selected then enter the URL for the content.
Editing/Moving a Navigation Item
1. Mouse over the item you wish to edit/move.
2. Click the Edit option at the end of the item.
3. Modify the form on the right. To move an item, choose the new location in the Assign Link to Parent drop down.

Deleting a Navigation Item
1. Mouse over the item you wish to remove.
2. Click the red X option at the left corner of the item.
3. You will be prompted by a question: This will be final are you sure? Click Yes, I’m sure.
The Assets module allows you to upload images and create folders to organize the files. See the reference in the Level 2 Template Section. To manage the Assets module, go to Add-Ons>Modules>Assets.

**Add A Sub Folder**

To add a sub folder to the Assets library, right click the root folder and choose **New subfolder**. Type a name in the pop-up box and click OK.

**Modifying Subfolders**

You cannot delete or alter the root folder, but you can rename, add, and delete subfolders. Right-click the subfolders to see these options.
Use the WYGWAM editor for your body content and lower content areas. This editor allows the user to add text, images, imbed video, tables, links, unordered lists, numbered lists, and more. The majority of the items on the Armstrong website will be added through the main screen as you see above. Specialized content, such as accordion tabs, will be added through the Source (HTML) editor.

Styles can be applied through the Format drop down.